NextCloud - 安全与设置警告优化解决方案

NextCloud 搭建好以后进入设置概况会提示存在错误,下面会对报错进行逐一解决。

其中数据库( 建立NextCloud数据库时字符集要选 utf8mb4 )MariaDB 10.2 及以上,Php7.3及以上。

安全与设置警告解决方案:

•  一些文件没有通过完整性检查。了解如何解决该问题请查看我们的文档。(无效文件列表…/重新扫描…)

此报错只需将上传的NextCloud解压文件包中的 .user.ini 复制到网站根目录进行覆盖即可,随后刷新报错解决。

•  您的数据目录和文件可以从互联网直接访问。.htaccess 文件不起左右。强烈建议配置Web服务器,以便数据目录不不再可访问,或者您可以将数据目录移动到Web服务器文档根目录。

在站点的配置文件中添加以下代码后 保存,刷新云盘站点页面。

location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/
    {
      deny all;
    } 

•  您的网页服务器未正确设置以解析“/.well-known/caldav”。更多信息请参见文档

•  您的网页服务器未正确设置以解析“/.well-known/carddav”。更多信息请参见文档。

打开云盘站点管理在配置中添加以下代码,重启Nginx服务即可。

•  HTTP的请求头 "Strict-Transport-Security" 未设置为至少 "15552000" 秒. 为了提高安全性,建议参照security tips ↗中的说明启用HSTS.

打开站点管理配置中加入以下代码,保存并重载Nginx服务。

add_header Strict-Transport-Security "max-age=63072000;";

•  PHP 的安装似乎不正确,无法访问系统环境变量。getenv("PATH") 函数测试返回了一个空值。 请参照安装说明文档 ↗中的 PHP 配置说明查阅您服务器的PHP配置信息,特别是在使用 php-fpm 时。

找到fpm选项加入以下代码 保存,并重启php服务。

env[PATH] = /usr/local/bin:/usr/bin:/bin:/usr/local/php/bin

•  PHP 内存限制低于建议值 512MB。

打开php管理,在配置修改中 脚本内存限制 中填入 > 512M 即可,重启Php服务。

•  所使用的数据库为MySQL但没有对4字节字符的支持。为正确处理文件名或评论中使用的4字节字符(比如emoji表情),建议开启MySQL的4字节字符支持。详细信息请阅读相关文档页面。

这是由于新建数据库的时候字符集未选择 utf8mb4 导致的(不建议折腾 需操作数据库)

•  未找到 PHP 的 "fileinfo" 模块。强烈推荐启用该模块,从而获得更好的 MIME 类型探测结果。

•  该实例缺失了一些推荐的 PHP 模块。为提高性能和兼容性,我们强烈建议安装它们 gmp ,imagick。

BT面板打开Php管理,在扩展中安装后重启php服务。

•  内存缓存未配置,为了提升使用体验,请尽量配置内存缓存。更多信息请参见文档。

打开NextCloud文件加入以下配置

'memcache.local' => '\\OC\\Memcache\\APCu',

或者

'memcache.local' => '\OC\Memcache\Redis',
'memcache.locking' => '\OC\Memcache\Redis',
    'redis' => array(
    'host' => 'localhost',
    'port' => 6379,
),

•  PHP 的 OPcache 模块未载入。推荐开启获得更好的性能。

在php配置文件末尾添加参数

#在[Zend Opcache]后添加
opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

作者:极客电玩 https://www.bilibili.com/read/cv9817730/

如有帮助请到原文三连支持一下

Comments

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注